2240869 - Database Upgrade Completion fails on JAVA-only systems | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2240869 - Database Upgrade Completion fails on JAVA-only systems

Symptom

Running SAP Tools to perform the During the Database Upgrade Completion with SWPM ends with error:

image_1.png

An error occurred while processing option Generic Installation Options > MS SQL Server > Database Tools >Database Upgrade Completion(Last error reported by the step: TypeError: si[0] has no properties (in script SAPMSSTOOLS_YUP|ind|ind|ind|ind, line xxxxx: ???))

Exploring the sapinst_dev.log file, you can find the following trace (the line numbers may vary):

 TRACE      2015-11-10 15:24:16.546 (NWDBOS\jn5adm) [ejscontroller.cpp:266]

 95420:   _componentDispatcher['SAPMSSTOOLSSUBCOMP_ind_ind_ind_ind_DialogPhase_dSetParamsCNV_Preprocess'] = function()
 95421: {
 95422:           return (
 95423:                                   (context.get("Task") == "CNV") || ((context.get("Task") == "YUP") && context.get("hasAbapSchema"))
 95424:                                 ) && !installer.goingBack();
 95425:         
 95426: }
 95427:
 95428:   _componentDispatcher['SAPMSSTOOLSSUBCOMP_ind_ind_ind_ind_DialogPhase_dSetParamsCNV'] = function()
 95429: {
 95430:         
 95431: var row = readParams();
 95432: var mss = new Mss();
 95433: mss.connect();
 95434: var si = mss.srv.dbGetSchemata(row.dbn, row.abs);
 95435: var old = (si[0].AbapRelease == '46C');
 95436: row.old = old;
 95437: saveParams(row);
 95438:     
 95439:       
 95440: }
 95441:
 95442:   _componentDispatcher['SAPMSSTOOLSSUBCOMP_ind_ind_ind_ind_DialogPhase_dSetTargetSchema_Preprocess'] = function()
 95443: {
 95444: return !installer.goingBack();
 95445: }
 95446:
 95447:   _componentDispatcher['SAPMSSTOOLSSUBCOMP_ind_ind_ind_ind_DialogPhase_dSetTargetSchema'] = function()
 95448: {
 95449:         
 95450: var t = new Table("t_MssMiscDialogs_CONTEXT");

A full dump of the javascript code can be found in file js_dump.log in the installation directory.


Read more...

Environment

  • SAP NetWeaver JAVA AS;
  • MS SQL Server 2005 and higher.

Product

SAP NetWeaver all versions

Keywords

upgradation fails, sapinst, saptools error, sapinst error, cannot upgrade, cannot upgrade, updatation, mssql, msql, ms_sql, Microsoft SQL Server, database error, SWPM SQL Database Upgrade Completion failing, failed, failled, fail , KBA , BC-DB-MSS , SQL Server in SAP NetWeaver Products , BC-INS , Inst.Tools - Use subcomponents; SAP Note 1669327 , BC-DB-MSS-UPG , SQL Server Upgrades in SAP NetWeaver Products , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.