2190126 - "Statement(s) could not be prepared" for repository upgrade - SAP PowerDesigner | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2190126 - "Statement(s) could not be prepared" for repository upgrade - SAP PowerDesigner

Symptom

  • During migration, following window message is displayed:

"The repository does not contain all the required definitions. You need to update the repositiory structure.
All other users must disconnect, and we recommended that you perform a full backup of the database before continuing.
Do you want to update the repository?" 

  • By clicking "Yes", error message is raised:

 "[Microsoft][ODBC SQL Server Driver][SQL Server]Statement(s) could not be prepared.
SQLSTATE = 37000"


Read more...

Environment

  • Repository migration from PowerDesigner 16.1 EBF 13 to PowerDesigner 16.5 SP05 PL01 (64-bit)
  • Repository DBMS: Microsoft SQL Server 2008 R2
  • SQL Server Version 6.01.7601.17514 ODBC driver

Product

SAP PowerDesigner 16.5

Keywords

powerdesigner, ODBC, SQL Server, repository, migration , KBA , upgrade , migration , repository , BC-SYB-PD , PowerDesigner , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.