2155627 - 'DBMS ASE is not supported in your current installation' - SAP PB | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2155627 - 'DBMS ASE is not supported in your current installation' - SAP PB

Symptom

  • After migration, a standard client/server application from PowerBuilder 11.5 to 12.6 (Classic) not able to connect to the DBMS.
  • No code change prior to migration. Migration itself completed without issue, running in "interpretive" mode via PowerBuilder 12.6 Classic IDE works fine, as does an application exe created in exactly same manner as in PowerBuilder 11.5 on development system.
  • After moving the PowerBuilder 12.6 application executable,  and all required runtime files to client system, the "Connect using SQLCA" fails with sqlcode of -1, sqldbcode of 999, and sqlerrtext of "DBMS ASE is not supported in your current installation...". Trying to connect to ASE 15.0.3, EBF 16383. Dev system, Client system, and DBMS all running on Windows.

Read more...

Environment

  • Sybase PowerBuilder
  • SAP PowerBuilder
  • Sybase ASE 15.0.3, EBF 16383

Product

SAP PowerBuilder all versions

Keywords

ase, syc, pbsyc126.dll, dbms, connect,powerbuilder,pb,deployment , KBA , BC-SYB-PB , Powerbuilder , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.