2141255 - Error using SQL Server 2008 JDBC 3.0 Drivers with some versions of XI 3.1 | SAP Knowledge Base Article

SAP Knowledge Base Article - Preview

2141255 - Error using SQL Server 2008 JDBC 3.0 Drivers with some versions of XI 3.1

Symptom

Error when attempting to create, test or consume a JDBC connection to Microsoft SQL Server 2008 JDBC 3.0 (sqljdbc.jar)

Java Exception : java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.


Read more...

Environment

  • SAP BusinessObjects Enterprise XI 3.1 (Reported version:  Support Pack 7)
  • Microsoft SQL Server 2008 R2 Database Server
  • Microsoft SQL Server JDBC (Version 3.0, sqljdbc.jar)

 

Keywords

jdbc unix solaris linux aix windows sqljdbc sqljdbc4 sqlserver mssql wis10901 java odbc unv universe connection , KBA , BI-RA-WBI , Web Intelligence , BI-BIP-SL , Semantic Layer , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.