SAP Knowledge Base Article - Preview

2134333 - Entity Framework 6.0 Version Compatibility Error

Symptom

When using SQL Anywhere 12 or SQL Anywhere 16 with Visual Studio 2012 or Visual Studio 2013 and Entity Framework 6 (see KBA 2075990), the following error is generated when attempting to connect to the SQL Anywhere database to select tables, views, and stored procedures for the Entity Data Model:

Your project references the latest version of Entity Framework; however, an Entity Framework database provider compatible with this version could not be found for your data connection. If you have already installed a compatible provider, ensure you have rebuilt your project before performing this action. Otherwise, exit this wizard, install a compatible provider, and rebuild your project before performing this action.


ef-error.png


Read more...

Environment

  • SAP SQL Anywhere 16
    SAP SQL Anywhere 12
  • Microsoft Visual Studio 2013
    Microsoft Visual Studio 2012
  • Entity Framework 6.1.1
    Entity Framework 6.1
    Entity Framework 6.0.2
    Entity Framework 6.0.1
    Entity Framework 6.0

Product

SAP SQL Anywhere 16.0 ; SAP Sybase SQL Anywhere 12.0

Keywords

sybase, EF6, VS2012, VS2013, Entity Framework, Version, Compatibility, EFTools, .Net, SQL Anywhere, iAnywhere, Visual Studio, Adaptive Server Anywhere, update, updating, upgrade, upgrading, app.config, provider , KBA , BC-SYB-SQA , SQL Anywhere (on premise, on demand) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.