SAP Knowledge Base Article - Preview

2016676 - PrerequisiteViolated error for the component LM-CTS during DEPLOY_ONLINE_SHD_DM phase of upgrade

Symptom

A system upgrade using SUM tool stops with an error during the phase DEPLOY_ONLINE_SHD_DM.

 You can refer to SUM logs for the below mentioned error :-

 

"May 7, 2014 7:20:10 PM   Error: com.sap.ASJ.dpl_api.001038 Validation Exception during deployment phase [ValidationException],cause=[[ERROR CODE DPL.DC.3085] An error occurred while checking the deployment items selected for deployment.The following 2 deployment items are not admitted for deployment: 1sdu id: [sap.com_tc~cts~appl] sdu file path: [/sum/SUM/sdt/XD2/JC04/j2ee/cluster/server0/./temp/tc~bl~deploy_controller/archives/21/LMCTS10_0-20007056_SCA1399486796292/DEPLOYARCHIVES/sap.com~tc~cts~appl.ear] version status: [HIGHER] deployment status: [PrerequisiteViolated] description: [   1. The component is met more than one time within the deployment batch. As it differs by its properties than the others same components into the batch, the Deploy Controller cannot decide which one has to be deployed.  Other sdu:name: [tc~cts~appl], vendor: [sap.com], location: [MAIN_APL70P28_C], version: [11891887], software type: [J2EE], csn component: [], dependencies: [[name: 'tc~cts~transport_api', vendor: 'sap.com', name: 'tc~sec~vsi~interface', vendor: 'sap.com']], archive type: [DC]] 2sdu id: [sap.com_tc~cts~appl]sdu file path: [/sum/SUM/sdt/XD2/JC04/j2ee/cluster/server0/./temp/tc~bl~deploy_controller/archives/21/DICMS30_0-10003499_SCA1399486807460/DEPLOYARCHIVES/tc~cts~appl.sda]version status: [HIGHER]deployment status: [PrerequisiteViolated]description: [ 1. The component is met more than one time within the deployment batch. As it differs by its properties than the others same components into the batch, the Deploy Controller cannot decide which one has to be deployed."


Read more...

Environment

Release upgrade or EHP installation

Product

SAP NetWeaver 7.0 ; SAP NetWeaver 7.3 ; SAP NetWeaver 7.4

Keywords

LM-CTS ,DI_CMS , ERROR CODE DPL.DC.3085 , KBA , BC-UPG-TLS-TLJ , Upgrade tools for Java , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.