SAP Knowledge Base Article - Preview

1989129 - Execution of java-based stored procedure following upgrade to ASE 15.0.3 fails with error 10762 "Cannot initialize the Java Virtual Machine .." - ASE 15.0

Symptom

  • ASE upgraded from ASE 15.0.x to 15.0.3 or later.
  • Execution of a java-based stored procedure which worked prior to upgrade, fails following upgrade.
  • Error returned similar to:

Msg 10762, Level 16, State 1:
Server 'SYBASE', Procedure 'MyJavaProc', Line 688:
Cannot initialize the Java Virtual Machine because either the Java class library or PCA plugin library is missing, corrupted, or incompatible with the current server release. Contact your System Administrator for help.
(return status = -6)

  • ASE boot sequence following upgrade to ASE 15.0.3 shows:

server Initializing Java services.
kernel PCI(M0): WARNING: There is NO configured JavaVM in place. Unable to continue executing Java in ASE
server Failed to initialize Java services.


Read more...

Environment

Sybase Adaptive Server Enterprise (ASE) 15.0.3 (or later) when upgraded from SAP ASE 15.0.x

Product

Sybase Adaptive Server Enterprise 15.0

Keywords

KBA , BC-SYB-ASE , Sybase ASE Database Platform (non Business Suite) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.