SAP Knowledge Base Article - Preview

1976240 - Cannot determine the SQLAnywhere version of the data tier

Symptom

  •  The upgrade process of Sybase Unwired Platform fail with the error "Cannot find "12.0" from the version query output.Cannot determine the SQLAnywhere version of the data tier so cannot determine whether it has been updated yet." as shown below:

test.png

  • Upgrade logs* show the following:
Calling "D:\Sybase\UnwiredPlatform\Servers\SQLAnywhere12\BIN32\dbisql.exe" -nogui -c "dsn=default-cdb_32bit;uid=dba;pwd=cdbuserpwd" -onerror continue "D:\sp5\\versionquery.sql"
Returned code is 9. Ignoring error code since it is not reliable. Proceeding with upgrade.
Cannot find "12.0" from the version query output. Cannot determine the SQLAnywhere version of the data tier so cannot determine whether it has been updated yet. It needs to be updated before updating server nodes. Exiting...

 

*Upgrade logs are located in <Sybase_install_dir>\UnwiredPlatform\Servers\UnwiredServer\sup22sp<xx> where xx denotes the patch level

 


Read more...

Environment

  • Sybase Unwired Platform (SUP) 2.2 SPxx
  • All Supported Backend Systems
  • All Supported Windows Operating Systems
  • All Supported Mobile Devices/Operating Systems

Product

Sybase Unwired Platform 2.2

Keywords

KBA , MOB-SUP-RT , SUP Runtime , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.