SAP Knowledge Base Article - Preview

1830600 - Import of delivery units failed / Cannot resume broken upgrade when doing the followup upgrade

Symptom

The upgrade of the HANA database with SUM (Software Update Manager), fails with the following error in /var/tmp/hdbupd.log:

INFO: -----------------------------------------------------------

INFO: END: Importing delivery units

INFO: -----------------------------------------------------------

ERR: Upgrade failed

ERR:   error upgrading

ERR:     Import of delivery units failed

ERR:       Cannot import delivery unit /hanamnt/<SID>/global/hdb/auto_content/HANA_XS_FORMLOGIN.tgz

The actual root cause of this error is further up in the log file and can be varying between the following messages, all of them indicating the calling the regi tool to import the delivery units failed:

ERR:   Error importing delivery units

ERR:     Cannot execute program /usr/sap/<SID>/HDB<xx>/exe/regi: /usr/sap/<SID>/HDB<xx>/exe/regi: No such file or directory

OR

ERR:     Import of delivery units failed

ERR:       Connect failed: ERR: Connect failed (code = -10709): Connection failed (RTE:[200107] Missing logon credential)

OR

ERR:     Import of delivery units failed

ERR:        Invalid SYSTEM user password.

Nevertheless, the database is still consistent and technically, the database was upgraded successfully. Whether the failing delivery unit import has an impact on the business cannot be answered in general. The delivery units are relevant in case the XS engine is used and there are applications that depend on it. Verifying the database for example via the HANA Studio would show that the software is already on the new revision.

Even if this error has no immediate impact, it can lead to the upgrade being left in an unfinished state. Therefore, the next upgrade will report the following error in the SUM (Software Update Manager) logfile /usr/sap/<SID>/SUM/log/ljs_trace.log:

ERR: Upgrade failed

ERR:   running in batch mode

ERR:     Cannot resume broken upgrade of '<SID>': wrong version (1.00.51.374135)

ERR:     SAP HANA Database installation kit '1.00.50.373820' required

Read more...

Environment

  • SAP HANA Database
  • SUM (Software Update Manager)

Product

SAP HANA 1.0, platform edition

Keywords

selfupdate of SUM; regi tool; hdbupd; hdbupgrade; , KBA , HAN-LM-PLT , SAP HANA Platform Lifecycle Management , HAN-DB , SAP HANA Database , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.