SAP Knowledge Base Article - Public

3121065 - Occasionally get 401 error when connect to external endpoint - [ Service Event Bus - SEB]

Symptom

  • When you work on SEB external event integration scenarios, some of the scenarios for the defined subscriptions are not triggered as expected.
  • In the "Event Notification Audit Log" tool of SAP SuccessFactors Admin Center, failed events show an HTTP response "401 null" error reported from the endpoint. 
    Caused by: org.apache.cxf.transport.http.HTTPException: HTTP response '401: null' when communicating with



Environment

SAP SuccessFactors HXM Suite

Cause

  • We're aware of this issue and are working on resolving it as part of PLS-23600
  • This error can be caused by two reasons:
  1. incorrect configuration in the integration.
  2. the error reported and described in this known issue.

Resolution

Workaround: Update the token expire time in the OAuth token service for the erroneous subscriptions and extend it to 30 days. Make sure the change takes effect.

Keywords

KI2111, PLS-23600 , KBA , LOD-SF-PLT-SEB , Service Event Bus Framework , Known Error

Product

SAP SuccessFactors HXM Suite all versions

Attachments

Pasted image.png