SAP Knowledge Base Article - Preview

3112418 - JAVA version is not correct. The supported versions are 1.7 and 1.8: SCC upgrade issue

Symptom

SAP Cloud Connector (SCC) upgrade fails and the below error is visible in the logs:

*********************************
Failed to stop scc_daemon.service: Unit scc_daemon.service not loaded.
search for java installations ...
Could not find Java installation. Will check JAVA_HOME.
Found /usr/lib64/jvm/jre-11-openjdk/bin/java and will use it during installation.
JAVA version is not correct. The supported versions are 1.7 and 1.8. Current java is <JAVA version>

*********************************


Read more...

Environment

  • SAP Cloud Connector
  • Release Independent

Product

Identity Authentication all versions ; SAP Business Technology Platform 1.0 ; SAP Connectivity service 2.0

Keywords

Production ABAP R/3 ERP SRM CRM ERP PPM SEM APO XI PI PORTAL Test development QA KBA On Premise HANA Database SAP Cloud Platform Cloud Connector xsodata On-Premise Access Control HANA DB Cloud to On-Premise HTTPS connection ABAP com.sap.scc.rt SccEndpointValidator OpenJDK Oracle JDK 64-bit SAP JVM 64-bit (recommended) SapMachine , KBA , BC-MID-SCC , SAP Cloud Connector On-Demand/On-Premise Connectivity , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.