SAP Knowledge Base Article - Public

3112070 - Workflow Rule Does Not Create E-Mail Activity On Object

Symptom

Workflow Rule E-Mails do not automatically create E-Mail activities on the BO they were sent out for.

Environment

SAP Cloud for Customer

Reproducing the Issue

You have an active workflow rule of type e-mail.

Your expectation is, that after an e-mail was sent, an e-mail activity should be recorded on the corresponding object BO.

However, when you check the object's Activities facet, the corresponding e-mail activity is not shown.

Cause

The object ID is not set as placeholder in the subject AND / OR the indicator: Create E-Mail Activity was not set.

Resolution

  1. Include the object ID placeholder in the e-mail subject of the workflow rule e-mail.
  2. Check the 'Create E-Mail Activity' indicator in the workflow rule. 

CreateEMailActivity.png

See Also

KBA 2534062 - E-mail Sent Via Workflow Rule Does Not Show Up In Ticket Interactions

Keywords

Missing, E-Mail, Email, indicator, activity, workflow, BO, facet , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications 2108