SAP Knowledge Base Article - Public

3104406 - Personalization for Sending on Behalf Of Not Working

Symptom

You have created an email with personalization for Sending on Behalf Of settings based on the account team members. When sending test emails for contacts which have a relationship with account team members, the email is not sent with the respective account team member.

Environment

SAP Marketing Cloud

Reproducing the Issue

You have created an email with personalization for Sending on Behalf Of settings based on the account team members. Also, the Contact ABC (Where ABC represents the contact ID) has an account assigned which contains team members.

  1.  Open the Email created.
  2.  Click on Test Email -> Send Using Contacts.
  3.  Select the Contact ABC and send also for your email.

The sender is not the account team member as expected.

Cause

The system does not consider the contact relationship (Account) team members to send the email using the personalizations of send on behalf.

 

The send on behalf will only check the team members of the Contact assigned to the contact itself, not the team members of the account.

 

Resolution

This is the current system design.

 

You can assign account team members for the Contact itself using the payload for Account Team Members.

Keywords

Sending on Behalf, Email , KBA , CEC-MKT-MEM , Content Studio: E-Mails and other messages , How To

Product

SAP S/4HANA Cloud 2108