SAP Knowledge Base Article - Public

3095762 - Relationship Creation In Customer TI Finds No Business Partner Results

Symptom

When creating a new Relationship on an account, no business partners are found.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite:

A new relationship type was created in the business configuration fine tuning activity 'Gernall Business Partners' > Maintain Relationships: Z123 Example (Z123 Example is an example name for the relationship created). The settings are set for:

Directional relationship and is Active. Further:

  • BP1 = Organization has set as allowed: Customer 
  • BP2 = Person has set as allowed: Contact & Partner Contact 
  1. Go to the Customers work centre
  2. Go to the Accounts view
  3. Open example account ABC (ABC represents an account in your system for which contacts are maintained)
  4. Go to the Relationships facet
  5. Select 'Add' and select the newly created Relationship type: 'Z123 Example'
  6. Select the Business Partner ovs

RESULT: no contact persons are found.

Cause

As the Business Configuration is set as Person only allowed for: Contact & Partner Contact, the list will not load when clicking 'Add' as this search includes business partners which are not contacts, or partner contacts.

Resolution

  1. Repeat steps 1. - 4.
  2. Click 'Add Contact' and select Relationship type: 'Z123 Example'
  3. Select the Business Partner ovs

Result: the list loads as expected.

Keywords

relationship, not found, missing, empty, business partner, contact , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 2108