SAP Knowledge Base Article - Public

3093112 - Existing Candidate is unable to accept the DPCS when signing in from Quick Apply Application - Recruiting Management

Symptom

  • After the DPCS has been updated, there is no option for an existing candidate to accept or decline the DPCS when signing in from a Quickapply application. The warning message is received - "The latest version of DPCS statement is not yet accepted by you. Please accept before proceeding".
  • The candidate may receive the following error in case they apply with an external candidate account that don't have the last DPCS version accepted.

       

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Update the DPCS statement in Admin Centre – Data Privacy statement.
  2. Navigate to the career site and apply to any QuickApply job.
  3. Click on "Sign in" from the application page.
  4. Notice how a warning message is displayed - "The latest version of DPCS2 statement is not yet accepted by you. Please accept before proceeding" however there is no option to accept or decline the statement.

Cause

This is currently the expected behavior from the currently system version.

There is a workaround in terms of changing the error message. Please refer to the Resolution tab.

Resolution

The candidate will have to sign in to their account to accept the DPCS statement either from the career site landing page, or from a non Quick Apply job application page.

There is an internal ongoing enhancement analyzes to have this behavior changed and let the candidate accept the new DPCS version while applying in a Quick Apply Requisition. For more information, you can reach out your CSM and refer the internal ticket - RCM-76205

Workaround:

As workaround, you can change the error message with the instructions on how the candidate can accept the newest DPCS version.

  1. Admin Center > Manage Languages
  2. Download Default Labels for the language in question to get the keys and current labels (Or the language in which this error message need to be displayed).
  3. They key for this message is "RECRUITING_APP_DPCS_VERSION_CHANGE_ERROR."
  4. Edit and Upload the custom label for this key with this text as per the requirement.

Sample text - "You will need to accept our most recent Data Privacy Statement in order to apply. Please click on “Return to List,” then “View Profile.” Scroll to the bottom and click on "Save." The new Data Privacy Statement will pop up, please read and click “Accept.” Navigate back to the job page to resume your application.".

See Also

There has already been an enhancement request submitted to change this system behavior.

Implementation Guide - Enabling Quick Apply in Job Requisition Template

Keywords

Data, privacy, statement, quick, apply, DPCS, error, RCM-76205 , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting 2011