SAP Knowledge Base Article - Public

3085492 - Sales Order (A2A) API not working for One-Time Customer

Symptom

You are not able to create a sales order for a one-time customer (CPD) using the A2A Soap API SalesOrderBulkRequest_In for sales orders due the following error message:

Address data of one-time customer * is incomplete.

"Image/data in this document is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 


Environment

SAP S/4HANA Cloud.

Reproducing the Issue

Although you are providing the necessary address data in the request, an error message is displayed and you are not able to create the sales order:

Error message at Message Dashboard app:

Cause

The system is checking the relevant BP master data address.

This is the standard system behavior.

Resolution

In order to overcome this error message and create the sales order, you need to maintain the relevant address data for the respective customer at the customer master data.

Go to Manage Customer Master Data -> Address tab

See Also

SAP Help Documentation - Sales Order (A2A)

Keywords

one time customer, one-time customer, CPD, A2A SOAP API, 013(SLS_LORD), 013, Sales Order (A2A), A2A, SalesOrderBulkRequest_In, onetime customer, customer account group, , KBA , SD-SLS-API , API , How To

Product

SAP S/4HANA Cloud all versions