SAP Knowledge Base Article - Public

3085091 - Email reminder is still "IN_PROGRESS" even after cancelling onboarding process - Onboarding

Symptom

Reminder email triggered even after Cancelling Onboarding and after restart Onboarding as well. 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to instance
  2. Go to Email Service -> Email Status
  3. Filter by [Name of Email Trigger].
  4. See that duplicate reminders are being sent.

Cause

Known defect.

  • Engineering Team have observed that upon cancelling onboardingProcess, emailReminders are still "IN_PROGRESS". This is not specific to restart flow. It is happening for cancelling onboarding flow.
  • When the Onboarding process is cancelled, the email reminder is not marked as cancelled resulting into emails being sent to the candidate even after the onboarding cancellation.

Resolution

WORKAROUND: We cancel the onboarding process, to mark the the email reminder state as Cancelled so as to stop sending further emails.

  1. Navigate to manage data
  2. In the first field enter EmailReminderState, enter the process id of the candidate.
  3. In the status field drop down,please select cancelled option.

PERMANENT FIX: Code-fix has been introduced and is scheduled to be deployed on 2h 2021 (b2111) release.

Internal Ticket: OBX-17230.

After the fix, email reminder should be marked as 'Cancelled'.

Keywords

OBX-17230, EmailReminderState, Email Services, Email Reminder, Duplicate email, OBX, ONB 2.0 , KBA , LOD-SF-OBX-EML , Notifications , Known Error

Product

SAP SuccessFactors Onboarding 2105