SAP Knowledge Base Article - Public

3072210 - Unable to add a Top N filter to a Level Based Hierarchy Dimension in SAP Analytics Cloud (SAC) & SAP Digital Boardroom

Symptom

The following error message occurs in SAP Analytics Cloud (SAC) when attempting to apply a TOP N Filter to a Level Based Hierarchy:

  • “Unable to retrieve data from the data source. Error: [Internal server error occurred while processing.]” 

Environment

  • SAP Analytics Cloud (Enterprise) 2021.7.7

Reproducing the Issue

  1.  Log in to SAP Analytics Cloud
  2. Open a Story based on an Import Data Connection
  3. Click on a Widget that is using a Level Based Hierarchy Dimension
  4. Click Sort
  5. Click Top N and select any N value eg. 10
  6. Click OK
  7. Observe the error message

Cause

This issue is currently under investigation by development.

Resolution

This issue is currently under investigation by development.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-DES , Story Design & Visualizations , Problem

Product

SAP Analytics Cloud 1.0