SAP Knowledge Base Article - Public

3070857 - User Can't Access Data Replication Monitor - "The Data Could Not Be Fetched"

Symptom

Certain Users have issues accessing the Data Replication Monitor. When accessing, they are thrown the following error:

"The data could not be fetched. Please try refreshing the browser page. If the problem persists, contact your system administrator."

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SuccessFactors 

Data Replication Monitor

Reproducing the Issue

  • Login to SuccessFactors as affected user
  • Navigate to Data Replication Monitor
  • Error appears

Cause

If we reproduce the issue with F12 developer logs on view, we can see the following error also thrown in those logs:

"en-US", "value" : "User xxxxxxx doesn't have the 'Employee Central Foundation API' access permission for FOLocation"


The new Data Replication monitor is based of OData API permissions  - and all necessary permissions would not be maintained.


Resolution

Ensure correct permissions are maintained.


Under User Permissions, select the Employee Central Effective Dated Entities category.

Under Job Information, select the View Current option for these fields:

  • Company
  • Country
  • Location
  • Employee Class
  • Pay Group


Review the handbook LINK for complete list of permissions.

See Also

2907140 - New Data Replication Monitor - 1H 2021 release - SAP SuccessFactors

Handbook link - Employee Central Data Replication Monitor

Blog posting - new Data Replication Monitor

Keywords

Data Replication Monitor, The data could not be fetched, access permission for FOLocation, access, permission, DRM 2.0 , KBA , LOD-SF-INT-DRM , Data Replication Monitor , LOD-SF-INT , Integrations , How To

Product

SAP SuccessFactors HXM Suite all versions