SAP Knowledge Base Article - Public

3057991 - Problems with the URL Token Resolution in the Recruiting Emails since the B2105 Preview release

Symptom

Note : This issue can be replicated in the Preview instances on the B2105 versions.

  • When an email contains the URL token (eg: Refer a friend / Reset Password trigger)  is send, sometimes the URL/Link can be too long (can be more than 7 lines of URL).
  • Therefore, this entire URL can be replaced with the a text, such that when clicking on the text it will redirect you to the appropriate URL.
  • After B2105 Preview release, the URL and the text both are coming as separate in the email along with the unresolved html code " "> "

Mail received Before B2105 Release :

Mail received After B2105 Preview Release :


DISCLAIMER : ALL THE IMAGES ARE TAKEN FROM THE SALES DEMO FOR THE DEMONSTRATION PURPOSE

Environment

SAP SuccessFactors Recruiting Management.

Reproducing the Issue

  1. Admin Center
  2. Managing Recruiting Email Templates
  3. Select any Template 
  4. Select any token that has URL / Link in it. Eg: [[LOGIN_URL]]


  5. In the template body in the source tab the URL / Link token "<a href ="http://[[LOGIN_URL]]">Anmeldung in Successfactors</a></p>" is not getting resolved when receiving the email

Editing any template in the Admin Center -> Manage Recruiting Email Templates -> Edit any template.


Cause

This issue is faced in b2105 Preview release

Resolution

Our engineering team has resolved this issue via b2105p9 (16-Jun-21). 

Keywords

Email, Link, URL, Token , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting 2105

Attachments

Pasted image.png
Pasted image.png