SAP Knowledge Base Article - Preview

3056284 - Intermittent issues with Webi reports using SSO via STS

Symptom

  • This issue was observed in a large distributed environment
  • Some errors in the DSL logs were 

invoke(): irrecoverable exception

getErrorMessage(): cannot obtain string. bundle: com/crystaldecisions/sdk/exception/internal/ServerMsgResources, strID: null_code
java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key null_code

SSO token or User password is empty.

Failed to connect to the OLAP source.

com.businessobjects.mds.olap.OlapException: com.businessobjects.mds.olap.OlapException: [Internal] SSO token or User password is empty.

  • Some errors in the STS logs were 

STS: server session not set yet, maybe the magic server token hasn't be set?

Exception raised from SecurityTokenService.getSAPAssertionTicketEx

  • To note in these issues the DSL and STS services were on different nodes making it difficult to trace without a proper end to end



Read more...

Environment

SAP Business Intelligence Platform 4.3 but could occur in other environments

Product

SAP BusinessObjects Business Intelligence platform 4.3

Keywords

KBA , BI-BIP-ADM , BI Servers, security, Crystal Reports in Launchpad , BI-RA-WBI , Web Intelligence , BI-BIP-AUT , Authentication, ActiveDirectory, LDAP, SSO, Vintela , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.