SAP Knowledge Base Article - Preview

3051119 - Workaround for ant npminstall not working in 2011.5

Symptom

npm/node has been updated in Hybris 2011.5, but the actual version definition was not changed in hybris/bin/modules/npm-ancillary/npmancillary/resources/npm/package.json. Therefore, the ant npminstall command fails with:

npminstall:
[echo] running npm install on npmancillary extension
[echo] Running [npm cache verify]
[exec] Cache verified and compressed (~/dev/rossmann2/rossmann_playground/server/hybris/bin/modules/npm-ancillary/npmancillary/resources/npm/.cache/_cacache):
[exec] Content verified: 0 (0 bytes)
[exec] Index entries: 0
[exec] Finished in 0.011s
[echo] Running [npm install --loglevel=error]
[exec] npm ERR! code ENOTSUP
[exec] npm ERR! notsup Unsupported engine for npmancillary@1.0.0: wanted: {"node":"10.23.2","npm":"6.14.10"} (current: {"node":"10.24.0","npm":"6.14.11"})
[exec] npm ERR! notsup Not compatible with your version of node/npm: npmancillary@1.0.0
[exec] npm ERR! notsup Not compatible with your version of node/npm: npmancillary@1.0.0
[exec] npm ERR! notsup Required: {"node":"10.23.2","npm":"6.14.10"}
[exec] npm ERR! notsup Actual: {"npm":"6.14.11","node":"10.24.0"}


Read more...

Environment

SAP Commerce 2011.5

Product

SAP Commerce 2011

Keywords

KBA , CEC-COM-CPS-COR , SAP Commerce Core , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.