SAP Knowledge Base Article - Public

3047101 - [[Username]] token could not be seen in email template (ONB) Furnish Equipment Trigger - Onboarding

Symptom

[[Username]] token in Email Services is not showing in (ONB) Furnish Equipment Trigger. However, this is showing to other templates.
Ex: (ONB) External User Welcome Message Trigger
Username token is showing in Trigger:  (ONB) External User Welcome Message Trigger

Environment

SAP SuccessFactors Onboarding 

Reproducing the Issue

1. Go to Email Services
2. Open any active (ONB) Furnish Equipment Trigger in Active Templates
3. Go straight to Step 3
4. In Body Text, click "+Insert Token"
5. Token [[Username]] is not showing.

Cause

The username token is not supported, it is not a defect. The way the system is designed, not all the tokens work in all the templates. Only the supported tokens are displayed in the list. 

Resolution

This is an expected behavior. If this is needed for your business, kindly raise an Enhancement request.

See Also

2905960 - [HOW TO] Add an existing email template to the active list in Email Services - Onboarding 2.0

3046976 - [ONB 2.0] - Duplicate (ONB) Prepare for New Team Member seen on Email Services

Keywords

ONB 2.0, [[Username]], (ONB) Furnish Equipment Trigger, Email Services , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding