SAP Knowledge Base Article - Preview

3042989 - SAPUI5 fails to load fragment after upgrading to SAPUI5 1.60.X and later (in relation to iconTabBar)

Symptom

  • Definition: What is a SAPUI5 fragment?
    • Fragments are light-weight UI parts (UI sub-trees) which can be reused, defined similar to views, but do not have any controller or other behavior code involved
    • UI parts which are to be used in several views cannot be easily defined
    • They either have to be created as new controls, or they have to be created as views
    • Creating them as new controls results in a development overhead, while creating them as separate views results in a runtime overhead. In the latter case they would have a separate controller instead of having the same controller as the view does
    • Also, views and popup controls like dialogs do not go well together
    • The dialog content can be defined as a view but the dialog control itself always has to be written in the program
    • To solve these issues, fragments have been introduced
      • They can be reused and, if source code is required and for event handler methods, they can connect to existing controllers of the "owning" view
      • This means that one important characteristic of fragments is that they are independent of the model-view-controller (MVC) concept and can be used without using MVC
      • However, if fragments are used together with views and controllers, fragments can make use of them and integrate them neatly
      • For more information please read Reusing UI Parts: Fragments (part of link pasted above - what is a fragment)
  • Fragment loading issue seen when comparing older SAPUI5 version to SAPUI5 version 1.60.X and later
    • It appears there is a change in the way the SAPUI5 refers to the local SAPUI5 library
    • Previously the application may have used the below library versions in the code:

      ~~~~~~Example~~~~~~~
      src=" https://sapui5.hana.ondemand.com/1.46.7/resources/sap-ui-core.js ".

      Note: This type of technique also seen in SAP application running SAPUI5 version 1.28.X
      ~~~~~~~~end~~~~~~~~~

    • Post system SAPUI5 upgrade to a later version 1.60.X or later appears the system have changed the way the local library is now sourced or loaded in the system

      ~~~~Example Now~~~~~~
      as src="resources/sap-ui-core.js"
      ~~~~~~end~~~~~~~~~~
    • With this seen changes to the local library, the fragment is not loading inside IconTabbar UI element (sap.m.IconTabBar)
    • Why would the IconTabbar start to fail with respect to fragments and the newer SAPUI5 1.60.X or later versions?


Read more...

Environment

 SAPUI5 1.60.X or later

Product

SAPUI5 1.0

Keywords

"sap.m.IconTabBar", "SAPUI5 IconTabBar","IconTabBar","SAPUI5 fragment","What is SAPUI5 fragment","changes in sourced library","loading sap-ui-core.js","difference in loading sap-ui-core.js","What changed in SAPUI5 in 1.60" , KBA , CA-UI5-COR , Core and Runtime , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.