SAP Knowledge Base Article - Public

3032728 - Default locale not working

Symptom

The default locale is not set for external onboarding user

Environment

SAP SuccessFactors Onboarding 2.0



Reproducing the Issue

  • Initiate onboarding for a candidate.
  • Complete the new hire data review step.
  • Once the New hire data review step is complete , the welcome email along with the login details will be set to the candidate.
  • Once the external onboarding user login to the application , either the locale is not set or it is set to incorrect locale.


Resolution

The below 2 configurations have to be checked.

  1. In SF provisioning , under the company setting we have to set the default locale.
  2. If the first configuration is correct , then we will need to check the HRIS sync mapping either in the manage business configurations or by downloading the template from provisioning under Succession Management. 

For set 2, if checking the manage business configuration check for the personalInfo  Hris element to check if their is any custom mapping for default locale field. If checking from the succession template , below is as example how the custom mapping will look like.

Once we identify the custom mapping in the HRIS Sync mapping , we will need to either remove the mapping or pass value for that respective field which is mapped.

Keywords

external user , default locale , onboarding  , KBA , LOD-SF-OBX-ACC , Accessibility , Problem

Product

SAP SuccessFactors Onboarding 2011