SAP Knowledge Base Article - Public

3031255 - Unable to create an Import Data Connection via a secured JDBC connection in SAP Analytics Cloud (SAC) & SAP Digital Boardroom

Symptom

The following behaviour occurs in SAP Analytics Cloud (SAC):

  • Unable to connect to a SQL Datasource with a secured JDBC connection
  • Unable to create an Import Data Connection when SQL datasource is secured with SSL / CA signed Certificate

Environment

  • SAP Analytics Cloud (Enterprise) 2021.1.x

Reproducing the Issue

  1. Create an Import Data Connection (Acquired) to a SQL Database via a Secured JDBC Connection
  2. Observe that it is not possible to create the connection 

Cause

Currently, when using Import Data Connections, it is not possible to connect to a data source via JDBC when it is secured with a SSL / CA signed certificate. The only Import Data Connection that currently supports this, is HANA (using TLS / CA or self-signed) as of the QRC 1 update of 2021.

Resolution

An enhancement request has been raised below, so to increase the likelihood of this feature being implemented in future releases of SAP Analytics Cloud, please vote below;

https://influence.sap.com/sap/ino/#/idea/262658/

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem

Product

SAP Analytics Cloud 1.0