Symptom
You open an integration to edit it and Integration Center gets stuck in a loading screen.
The issue occurs to all integrations, even when you try with another browser.
Environment
- SAP SuccessFactors HXM Suite
- Integration Center
Cause
If you open the browser logs (F12 in the keyboard) before the loading screen occurs, you'll be able to see that in the network tab there will be this in one of the calls performed:
{
"d": {
"SEFEventsList": {
"data": {
"results": []
},
"status": "SEF_STATUS_NO_PERMISSION",
"statusMsg": "You don't have the permission to view Event Center."
}
}
}
So the issue occurs due to lack of permissions in the user who is trying to edit the integration.
Resolution
Make sure the user that is editing the integration has the permission below:
- Intelligent Service Tools > Event Center
After that, the issue should be solved.
See Also
All the permissions necessary to use Integration Center can be checked in the guide page below:
List of Role-Based Permissions
You just need to search for "Integration Center" in the "Component" column.
Keywords
ic, integration center, missing, lack, permissions, permission, rbp, user, employee, sf, successfactors, stuck, freeze, freezing, froze, crash, crashes, , KBA , LOD-SF-INT-INC , Integration Center , Problem