SAP Knowledge Base Article - Public

3026737 - Filter keeps loading forever in Report Center

Symptom

In filter section of a Report, Click Refine Criteria - > Select Filter from Employee Custom Fields (standard elements custom01 - custome15) , e.g. choose custom04, the ''Define Filter'' page cannot load successfully but keeps loading forever.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.


Environment

  • SAP SuccessFactors Ad Hoc Reporting
  • SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to Report Center > Edit a Report > filter section
  2. Click Refine Criteria - > Select Filter from Employee Custom Fields (standard elements custom01 - custome15) , e.g. choose custom04
  3. Found the ''Define Filter'' page is never successfully loaded, just keep loading forever.

Cause

The root cause of this issue is that the filter which user selected is a picklist field and customer enabled "Sort Picklist Columns Based On Labels" in Provisioning.

Resolution

To resolve this issue, please disable option "Sort Picklist Columns Based On Labels" in Provisioning -> Company Settings. Please contact partner or raise incident to SAP Support to disable the option.

Please also be rest assured that Disabling "Sort Picklist Columns Based On Labels" won't have any negative impact to picklist data, picklist order on UI or anything in Picklist Center.

Keywords

PLA-18011, Filter search, Report Values, Ad Hoc, Ad-Hoc, AdHoc, Picklist, standard element, custom field, picklist type field , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-PLT , Platform Foundational Capabilities , How To

Product

SAP SuccessFactors HXM Suite 2011