SAP Knowledge Base Article - Public

3025179 - Offer approval has been routed to system user (v4admin) - Recruiting Management

Symptom

  • Unable to reassign offer approval from the system user to an active user
  • Offer approval is stuck with system user and the approver has no option to cancel or approve it

Environment

SAP SuccessFactors Recruiting Management

Cause

Offer approval form will be routed to the system user (v4admin) in the following scenarios. Frequency of this issue happening will be very low.

  • Approver became inactive
  • Approver did not have login permissions or login permissions were removed at some point

Resolution

Workaround

A possible workaround would be creating a brand new Job Requisition and having the candidate "re-applying" to it, so we can have a new offer approval sent to an active approver.

Note: Due to the corrupt data, we cannot change the offer approver from back-end.

Prevention

We will be adding some guardrails to avoid this issue. Some of those scenarios are complex and will be discussed with Product management. 

Please follow up this KBA in order to have further updates on the progress by clicking on the star.

See Also

KB article 2698630 - Terminated users with pending Job Requisitions or Offer Approvals

Keywords

RCM-92922, PMU-11680, unable to approve offer, offer stuck with system user, offer approval, reassign, inactive user, login permission, terminated user , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Known Error

Product

SAP SuccessFactors Recruiting all versions