Symptom
- When trying to synchronize a permission role between two instances, the sync is failing and providing the following error: Error: The RBP subject user field of object definition [OBJECT NAME] has different values between the source and the target instances;
- The RBP subject user field is the same in both instances.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Instance Sync;
- Select one RBP Permission Role to sync;
- Run the sync;
- Sync fails and you get the following error: Error: The RBP subject user field of object definition [OBJECT NAME] has different values between the source and the target instances.
- Go to the Object Definition in both environments and compare the RBP Subject User Field;
- See that the values are the same for both.
Cause
There is a known issue where the validation code for the RBP Subject User Field is not working properly when the field has a "." in the name. If there is the "." in the middle, it will consider as different values between the two instances.
Resolution
Our development team is working on the fix of this validation code, and the permanent fix will be delivered on 2105 release.
In the meantime, the workaround is to sync the RBP permission role manually between the two instances.
See Also
2971910 - Instance Sync Enhancement While Syncing Role-Based Permissions Artifact [2H 2020]
Keywords
Instance, Sync, IST, failed, error, RBP subject user name, RBP, MDF, object, MDF-41028 , KBA , LOD-SF-PLT-IST , Instance Sync Tool , Problem