Symptom
Sign in Document shows the following error:
"Error in getting document from DMS: Failed to download attachment: 0 from Object Store"
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
1. Log in as Onboardee
2. Click on Complete e-Signing of documents
3. Click e-Sign Documents
4. The error will show
Cause
This is a known issue that is being fixed internally in OBX-16230.
Root cause of the issue is that filenames of the documents with special characters such as "." is throwing an error in file type
Backend Error: inserted value too large for column: Failed in "FILE_TYPE" column with the value 'Filetype with special characters.pdf'
Resolution
While engineering is working for the permanent fix for this issue, workaround is that remove the special characters in the document and retry again.
Avoid using dot in the name of the document and the template. Rest will work like charm.
See Also
Keywords
ONB 2.0, DMS, Failed to download attachment: 0 from Object Store, , KBA , LOD-SF-OBX-DG , Generation of Documents using PFS , Known Error