SAP Knowledge Base Article - Public

3016450 - Unable to open Stories based on Live Data Connection to S/4HANA Cloud in SAP Analytics Cloud (SAC) Mobile App for iOS

Symptom

Unable to connect to Live Data Connection to S/4HANA Cloud (via OAuth) from the SAP Analytics Cloud Mobile App for iOS

  • Issue is not reproducible from a Web Browser on the same Mobile Device, or from Desktop

Environment

  • SAP Analytics Cloud (Enterprise) 2021.X.X
  • SAP Analytics Cloud Mobile App for iOS - 2.82.0
  • Apple iPhone with iOS 14.2

Reproducing the Issue

  1. Open SAC Mobile App
  2. Log in successfully
  3. Open Story based on Live Data Connection to S/4HANA Cloud via OAuth
  4. Observe that no Data is shown

Cause

"Optimized for iOS" is disabled.

Resolution

  1. Log in to SAP Analytics Cloud via Desktop and open the Story you wish to open in iOS
  2. In the top left, Click File > "Wrench Icon / Edit Story" > Story Details
  3. Under the "Optimized for iOS" option, enable this to benefit from the same WebView with optimized performance and loading for iOS. (see Example below)

Example:

optimize.PNG

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-MOB-IOS , SAC Mobile IOS specific , LOD-ANA-MOB-AND , SAC Mobile Android Specific , Problem

Product

SAP Analytics Cloud 1.0