Symptom
When trying to do a 'Verify' on Interview scheduling with Outlook Integration while "Exchange Online" is selected, there will be an error:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
1. Go to Admin center > Setup Interview Scheduling Outlook Integration
2. Choose "Exchange Online" and configure the each required fields from your Exchange / Azure portal
3. Click verify and you will receive a generic error
Cause
SF logs: service exception Error code: MailboxNotEnabledForRESTAPI
Based on SF error log above, this error can for various reasons:
The mailbox is on a dedicated Microsoft Exchange Server or is not a valid Office 365 mailbox.
The mailbox is an Outlook.com account that hasn't been enabled yet.
The mailbox is not part of an Office 365 plan that includes Flow.
Resolution
To fix this issue, use one of the following options, as appropriate for your situation.
Option 1: Migrate your mailbox account
If you don't have a valid Office 365 mailbox, you must submit a request to your Outlook administrator to migrate the mailbox account. Users who don't have administrator permissions can't migrate accounts. For information about how to migrate the mailbox account, see How to migrate mailbox data by using the Exchange Admin Center in Office 365.
Option 2: Wait for your mailbox to update, or request a developer preview account
Because enabling mailboxes on Outlook.com for the Outlook REST API happens over time, your existing Outlook.com account may still be in the queue. You can request a new, enabled Outlook.com developer preview account by sending an email message to outlookdev@microsoft.com.
Option 3: Upgrade your Office 365 plan
The following Office 365 plans include the "Microsoft Flow for Office 365" plan:
Office 365 Business Essentials
Office 365 Business Premium
Office 365 Education
Office 365 Education Plus
Office 365 Enterprise E1
Office 365 Enterprise E3
Office 365 Enterprise E5
For complete information, please review the guide provided by Microsoft via link https://docs.microsoft.com/en-us/exchange/troubleshoot/user-and-shared-mailboxes/rest-api-is-not-yet-supported-for-this-mailbox-error
See Also
Microsoft documentation - https://docs.microsoft.com/en-us/exchange/troubleshoot/user-and-shared-mailboxes/rest-api-is-not-yet-supported-for-this-mailbox-error
Keywords
Application permission, NoPermissionsInAccessToken, Graph API, Delegated permission, Application permission, exchange online , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem