SAP Knowledge Base Article - Public

3012119 - Referral emails redirecting to a blank page - Recruiting Management

Symptom

When a tries to access their referral email it redirects them to a blank page 


NOTE:Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

There were multiple scenarios done to reproduce the issue and it mainly involves existing External Candidate Profile and newly created External Candidate Profile.

Existing External Candidate Profile: 

1.Refer an already existing External Candidate.

2. Candidate receives referral email.

3. Candidate is directed to the job requisition and can apply.


Newly Created External Candidate Profile

1. Refer a non existing External Candidate.

2. Candidate receives an email and is redirected and prompted to change their password.

3. Once candidate creates their profile, candidate should apply to the requisition that they are referred to.

4. If in case the candidate did not apply immediately and opt in to apply later and click on the same referral link.

5. Candidate will be prompted to a blank page. 

Cause

As per our Engineering team, this is an expected behavior, the referral URL for non-existing/newly created Candidate Profile only works once, if Candidate tries to use the referral URL again, they will be redirected to a blank page. 

Resolution

Once non-existing Candidate receives the referral URL, the Candidate should proceed and apply immediately once Candidate Profile has been created. 

Keywords

Referral URL, Blank page, Candidate Referral  , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions