Symptom
You have extended and maintained the value of extension field in the customer invoice. But the value is not being shown in the Customer Account.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Customer Invoicing Work Center
- Go to Invoice Document View
- Find and open Invoice ABC(where ABC stands for the Customer Invoice)
- You can see the value of Extension Field XYZ (where XYZ stands for the Extension Field) has been maintained.
- Go to Receivables Work Center
- Go to Customer Accounts View
- Search for Customer Account EFG (where EFG stands for the Customer Account)
- Click View
- You can see the values of Extension Field XYZ is not being shown for Customer Invoice ABC
Cause
The Extension Field XYZ has been extended.
- Open Adaptation Mode
- Check the Extension Field XYZ
- Click Further Usage of Extension Field XYZ
- Check Extension Scenarios
- "Customer Invoice - General Information to Trade Receivables Payables Register – Item" has been checked
But the Extension Field is passed from Customer Invoice to Customer Account monitor when the Invoice is released. The Extension Field is passed through the XML message.Once the Invoice is released it ideally should be modified. In any case as the Invoice was already sent to accounting and to FIN operations it will not be sent again.
In this case, the Extension Field is updated after the Invoice has been released.
- Open Invoice ABC
- Navigate to Changes tab
- You can see the User maintained the value for Extension Field XYZ on DD.MM.YYYY is after the creation date of Journal Entry.
Hence updates to Extension Field will not be passed to financials again.
Resolution
You can only cancel the Invoice ABC and re-create.
Please ensure the Extension Field is maintained correctly before the creation of Journal Entry.
Keywords
Extension Field; Customer Invoice; Customer Account , KBA , SRD-CRM-ORD , Orders & Contracts , Problem