SAP Knowledge Base Article - Preview

3009121 - The required provider[iaik.security.ec.provider.ECCelerate] is not installed

Symptom

The SAP Application Server Java applications/services fail to start and the below error is logged in the trace files (std_server /default traces):

*********************************************************
Caused by: java.security.KeyStoreException: The required provider[iaik.security.ec.provider.ECCelerate] is not installed:
Caused by: java.lang.RuntimeException: IAIK JCE is not recent enough. ECCelerate requires at least version 5.51.
*********************************************************


Read more...

Environment

  • Release Independent
  • SAP NetWeaver

Product

SAP Composition Environment all versions ; SAP NetWeaver 7.5 ; SAP NetWeaver Application Server for Java all versions ; SAP NetWeaver all versions ; SAP Process Integration all versions ; SAP Solution Manager all versions

Keywords

SAP Production ABAP R/3 ERP SRM CRM ERP PPM SEM APO XI PI PORTAL Test development QA, ENGINEAPI SERVERCORE J2EE-FRMW J2EE-APPS java.lang.NoSuchMethodError exception Java Virtual Machine ClassLoader java.lang.NoClassDefFoundError instance incompatible intertwined dependencies 1794179 1715441 1974464 BC-JAS-SEC sap.com/userstore NoSuchActionException , KBA , BC-JAS-SEC , Security, User Management , BC-JAS-COR , Enterprise Runtime, Core J2EE Framework , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.