SAP Knowledge Base Article - Public

3003720 - "Error executing the user/group operation" when calling SCIM API's in SAP Analytics Cloud(SAC)

Symptom

After an application has been working for a while, the SCIM api's may suddenly start failing and throwing the error

{
"status": 500,
"message": "Error executing the user/group operation."
}

Authentication still works, just the API's are failing.

Environment

  • SAP Analytics Cloud (Enterprise) 2020.21.11

Reproducing the Issue

  1. Log onto Hub using the RESTful APIs
  2. After authenticating, attempt to call one of the API's (such as https://<Tenant URL>/api/v1/scim/Users
  3. Get the error

Cause

This issue is currently under investigation by development.

Resolution

This issue is currently under investigation by development.

Note: A workaround is to recreate the OAuth application on the SAC side.  Once that is done, the API calls will start working again.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-AUT , SAC Authentication / Login , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0