SAP Knowledge Base Article - Public

2994256 - Authentication errors, such as: “Error Code: FAILED_AUTHENTICATION, Error Message:” - Message No. HRSFEC_PTP096

Symptom

While replicating from SuccessFactors Employee Central to Employee Central Payroll environment, some of the following authentication errors may be raised in transaction SLG1:

 

  • Error Code: FAILED_AUTHENTICATION, Error Message:
    • Message No. HRSFEC_PTP096
  • Authentication failed, invalid user id or password(status code = 4)
    • Message No. HRSFEC_PTP102
  • Employee Central login failed (2020-11-13 17:33:36.3115120)
    • Message No. HRSFEC_PTP031
  • Aborted employee replication based on external employee IDs (2020-11-13 17:33:36.3116730)
    • Message No. HRSFEC_PTP099

Environment

Employee Central Payroll

Point to Point Replication

Reproducing the Issue

  1. Access transaction SE38;
  2. Run report RP_HRSFEC_PTP_EE_REPLICATION with the required Configuration ID and External Employee ID;
  3. Go to transaction SLG1, and search to the employee you’ve just replicated;
  4. See the errors.

Cause

The password for user SFAPI that was registered in Employee Central Payroll environment has been changed in SuccessFactors Employee Central.

So on, due to this, an invalid user and password combination saved in transaction HRSFEC_PTP_CONFIG / report RP_HRSFEC_PTP_CONFIGURATION are the cause of this issue.

To confirm this, you can also access this transaction/report, and execute the ping test:

  1. Access transaction HRSFEC_PTP_CONFIG / report RP_HRSFEC_PTP_CONFIGURATION.
  2. Run it with the Ping Employee Master Data API flag marked.
  3. The following errors will also be raised:
    • SOAP login/logout HTTP status code: 200
    • SOAP request error code: FAILED_AUTHENTICATION
    • Authentication failed, invalid user id or password(status code = 4)

In addition, once this issue is related to incorrect user and password configuration, most likely, it will be blocking all the integration between SuccessFactors Employee Central to Employee Central Payroll, and with this, no employee will be replicated.

Whether it is necessary to debug the scenario, error message HRSFEC_PTP096 is raised in class CL_HRSFEC_PTP_EE_REPLICATION, method EC_LOGIN.

Resolution

It is necessary to correct configure the user and password combination saved in transaction HRSFEC_PTP_CONFIG / report RP_HRSFEC_PTP_CONFIGURATION.

In order to accomplice that, access this transaction/report, and correctly run it with the “Set Connection Data” option set.

Please refer to the “See Also” bellow, which indicates the Employee Central to Employee documentation guide regarding this configuration.

See Also

Employee Central Payroll using Point-to-Point Integration
Set up the Connection to Employee Central

Keywords

Authentication errors; HRSFEC_PTP096; HRSFEC_PTP102; HRSFEC_PTP031; HRSFEC_PTP099; HRSFEC_PTP_CONFIG; RP_HRSFEC_PTP_CONFIGURATION. , KBA , LOD-EC-GCP-PY , Payroll Integration EC to Employee Central Payroll , Problem

Product

SAP SuccessFactors HXM Core 2005