SAP Knowledge Base Article - Public

2989838 - Reset password URL in Welcome Notification navigating to login Page After Onboaring user is hired via Manage Pending Hire

Symptom

Onboarding user ( 1.0 ) is unable to reset password when the user receives the second welcome email once hired via manage pending hires the reset password link in the 2nd welcome email will redirect to the Login Page and the user will be unable to reset password. 

Environment

SAP SuccessFactors HXM Suite 

Reproducing the Issue

  1. Create an onboarding user  1.0 (not ONB2.0)
  2. Onboarding user will receive the 1st welcome email that triggered by ONB, welcome email contains Login username and reset password link.
  3. Onboarding user clicks the reset password link and reset the password successfully.
  4. Hire the onboarding user via Manage Pending Hire
  5. After hired this onboarding user via Manage Pending Hire, this user will receive 2nd welcome email, this welcome email also contains Login username and reset password link
  6. Click that reset password link in 2nd welcome email and it won't work and redirects to login page.

Cause

Engineering are investigating and working on a permanent fix to correct the flag when the second email is sent out for Onboarding Users who are hired using Manage Pending hires internal reference ECT-148213. This defect only persists in ONB 1.0 users. 

Resolution

Engineering are investigating and working on a permanent fix to correct the flag when the second email is sent out for Onboarding Users who are hired using Manage Pending hires internal reference ECT-148213. This defect only affects ONB 1.0 users.

Workaround:

  1. The user is not required to reset password from 2nd Welcome email to login, use still can login with previous password they reset in 1st welcome email even though username changed.
  2. Admin user can reset password for the affected user via Admin Center -> Reset User Passwords.
  3. Additional Engineering can execute a script. For engineering to execute the script for the affected user/s kindly share user details and provide customer approval in the case. 

Keywords

ECT-148213 , welcome email , directing to login page , manage pending hires  , KBA , LOD-SF-PLT-PWD , Password Policy Settings & Reset Password , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors HXM Suite 2011