SAP Knowledge Base Article - Public

2987558 - Missing or Truncated Information in Candidate Profile When Uploading a Resume - Recruiting Management

Symptom

When uploading a resume in the external career site (RMK), the resume does not successfully get parsed and the information is not getting populated.

When uploading a resume, the Address is getting truncated and Zip Code is not getting populated. 

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

Scenario A: 

Prerequisites:

Resume Parsing is enabled 

Mobile Apply is enabled

  1. Go to the RMK site
  2. Click on Search jobs
  3. Select a job
  4. Click on Apply Now
  5. Create a new account
  6. Fill in all the details
  7. Create account
  8. Activate the account
  9. Continue to Apply
  10. Enter the Credentials and Sign in
  11. Go to My documents > Resume/CV
  12. Select a file and upload
  13. Resume does not get parsed

Scenario B:

Prerequisites:

Resume Parsing is enabled 

Mobile Apply is not enabled

  1. Go to the RMK site
  2. Click on Search jobs
  3. Select a job
  4. Click on Apply Now
  5. Create a new account
  6. Fill in all the details
  7. Create account
  8. Activate the account
  9. Continue to Apply
  10. Enter the Credentials and Sign in
  11. Go to My documents > Resume/CV
  12. Select a file and upload
  13. Resume does not get properly parsed: Address information is truncated and Zip/Postal Code is not getting populated

Cause

As per the current implementation of the code, the resume parsing functionality is working as expected. As per the existing code, SuccessFactors never shows the parsed resume values in the UI when Mobile apply is Enabled. SuccessFactors is only showing the values from the Data Base in case Mobile apply is Enabled. 

With Mobile Apply disabled: regarding the Address, ZIP and other basic properties, whatever TextKernel thirdparty tool understands from the content in the resume, it will send them to SuccessFactors. The results of the TextKernel resume parsing vary based on the content in the resume, the format of the resume, resolution and aspect ratio of the resume (in case of Image format).

Resolution

A prevention ticket has been created to address the issues when Mobile Apply is disabled. Please reach out to your CSM and provide the following reference ticket: RCM-84952.

See Also

2582786 - Candidate profile import / Candidate creation through API and resume parsing - Recruiting Management

2733185 - Resume Parsing Not Filling the Information in Candidate Profile - Recruiting

2081576 - Resume Parsing in SuccessFactors Recruiting

2678328 - Resume Parsing / Social Profile behavior between Legacy RCM Candidate Profile and Mobile Apply (RMK enabled) - Recruiting Management

Keywords

Resume Parsing, Mobile Apply, Job Application, Address, Zip Code, incomplete, partial, shortened, truncated , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions