Symptom
The Imminent Candidate Purge Email Notification is not being triggered for any candidates on the instance.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Create a new Purge Rule for External candidates and configure the amount of days for the candidate to receive the notification;
- Wait for the amount of days set for the candidate to receive the purge notification;
- Notice that the candidates will not receive any purge notifications and will be purged.
Cause
This is caused by Intelligent Services Notification not being enabled on the environment.
Resolution
The way the Imminent Candidate Purge Email Notification is designed to work is by using the Kafka service, which relies on the Intelligent Services to create the job that will send the email to the candidates. In case ISC is not enabled on the instance, the Imminent Candidate Purge email notifications will not be sent to candidates.
Check if Intelligent Services Center is enabled on your environment, if it isn't, it can be enabled through Upgrade Center: 2599403 - Enable Intelligent Services Centre using the Upgrade Centre(ISC)
See Also
2599403 - Enable Intelligent Services Centre using the Upgrade Centre(ISC)
2919317 - RCM GDPR - Imminent Candidate Purge Email Notification - Recruiting Management
Keywords
candidate, email, purge, notification, imminent, intelligent, services, center, not, trigger, received, sent , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem