SAP Knowledge Base Article - Public

2974309 - Error: Assigned Business Role INV_SOL_GW_END_USER Does Not Exist

Symptom

  • You are unable to assign users to any business role. When selecting any business role and assigning it to the user, an error occurred. Error: Assigned business role INV_SOL_GW_END_USER does not exist.
  • You observed that you cannot see the business role INV_SOL_GW_END_USER in the UI. It looks like that it is assigned to the user in the backend.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator work center
  2. Click on Business Users view
  3. Search for the relevant business user
  4. Click on the three dots
  5. Click on Update Access Rights
  6. Click on Update All Users
  7. Click on Confirm
  8. Click on Show Background Runs for All Users
  9. Click on Display Logs
  10. Click on Results

Cause

The reported business role INV_SOL_GW_END_USER has been deleted in the system from the backend. Since the deletion is not allowed when the role is assigned to any user, it has been recreated in the system by a background job. Even if it has been recreated, it is not showing as expected in the UI.

Resolution

Please open an incident and approve backend correction.

Keywords

Business role, seever-side integration, Outlook integration, INV_SOL_GW_END_USER, , KBA , LOD-CRM-INT-OEM , Provisioning issues for OEM integration (eg iCRM) , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions