Symptom
You have set up an e-mail notification workflow with Title placeholder mapped to contact's title. However, in the e-mail, the title is in different language than expected.
For example, contact has title maintained as 'Herr' in German and e-mail was sent in German. But in the e-mail, title shows 'Mr.' in English instead.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log in with language ABC (ABC represents the logon language).
- Go to the Service work centre.
- Go to the Tickets view.
- Open ticket XYZ (XYZ represents the ticket ID).
- Go to the Interactions facet.
- Observe e-mail sent is in language ABC, but title is in different language.
- Open respective contact from the ticket.
- Observe title is maintained in language ABC.
Cause
Workflow placeholder language is determined based on preferred language of contact of the account. The logged in user's language is not considered.
Resolution
The language for placeholders is determined as follows:
- If the recipient is an employee, then identity settings are checked for preferred logon language. If no settings are maintained or the recipient is a customer/contact, then the business partner's preferred correspondence language is checked.
- Based on the language determined above, the corresponding template is searched. If there is no template maintained in this particular language, then the template with default template on the rule is picked.
Keywords
E-mail, interaction, ticket, placeholder, language, translation, template, workflow, determination , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-SRP-INT , Ticket Interactions , Problem