SAP Knowledge Base Article - Public

2966252 - Roles are revoked when Scheduling a Publication in SAP Analytics Cloud (SAC) & SAP Digital Boardroom

Symptom

When SAML Role Mapping is enabled for Role Assignment for a particular user, the Activity Log shows that the Roles are revoked upon Scheduling a Publication in SAP Analytics Cloud (SAC):

  • Issue does not persist when Roles are assigned manually eg. within the Users page (Menu > Security > Users)
  • Insufficient Roles can cause the Schedule to fail

Environment

  • SAP Analytics Cloud (Enterprise) 2020.14.4

Reproducing the Issue

  1. Log in to SAP Analytics Cloud
  2. Open a Story
  3. Click Share > Schedule a Publication
  4. Share Publication with any user
  5. Check Activity Log and observe Roles are revoked

Cause

This issue is currently under investigation by development.

Resolution

This issue is currently under investigation by development.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-DES , Model, Story Design & Visualizations , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0