SAP Knowledge Base Article - Public

2966196 - CompoundEmployee [Invalid SFQL! Error: QueryMode DELTA not possible for as XXXXXXXXX MDF version history was not active before yyyy-mm-dd ]

Symptom

You are observing the error messages in your SFAPI CompoundEmployee response:

  • [EXCEPTION] Exception=[SFAPI Domain Error!] Error Code=[INVALID_SFQL]
  • Error Message=[Invalid SFQL! Error: QueryMode DELTA not possible for as XXXXXXXXX MDF version history was not active before yyyy-mm-dd ]

Environment

  • SAP SuccessFactors HXM Suite
  • CompoundEmployee

Reproducing the Issue

Run the SFAPI CompoundEmployee and check the response received by the API under Admin center > SFAPI Audit logs or your middlewares.

Resolution

The error message QueryMode DELTA not possible for SOME_entity_portlet as MDF version history was not active before yyyy-mm-ddT00:00:00Z

This happened because you are using using an last_modified_on in the WHERE segments of the CompoundEmployee > to_datetime('yyyy-xx-xxThh:mm:ssZ'), that is before the "yyyy-xx-xxThh:mm:ssZ" (Date of the object in the EC configuration).

Also in futute we will forbid to use last modified date more than 3 months in the past.

Here are even more information about the new restriction: https://community.successfactors.com/t5/Employee-Central-Resources-Blog/Compound-Employee-API-Change-to-Last-Modified-On-amp-Snapshot/bc-p/255618#M548

Also in the KBA 2784576 - Compound Employee API Change to Last Modified On & Snapshot Date – H2 2020

Keywords

[EXCEPTION] Exception=[SFAPI Domain Error!] Error Code=[INVALID_SFQL], Error Message=[Invalid SFQL! Error: QueryMode DELTA not possible for as XXXXXXXXX MDF version history was not active before yyyy-mm-dd ], SAP SuccessFactors HCM HXM Suite, CompoundEmployee , KBA , LOD-SF-INT-CE , Compound Employee API , LOD-SF-INT , Integrations , How To

Product

SAP SuccessFactors HXM Suite all versions