SAP Knowledge Base Article - Public

2961910 - How to fix manual restart for candidates created through 3rd party ATS systems - Onboarding 2.0

Symptom

How to fix manual restart for candidates created through 3rd party ATS systems?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.  

Environment

SAP Successfactors Onboarding 2.0

Reproducing the Issue

  1. Go to Onboarding Dashboard;
  2. Open your candidate;
  3. In actions, select restart onboarding;
  4. After that, you'll not find your candidate in Onboarding Dashboard.

Cause

One of the possible causes is that your Onboardee does not have a valid value for manager-id field or this field is not enabled in Manage Business Configuration > JobInfo entity.

Resolution

In order to prevent issues with new candidates, please enable manager-id field. For fixing "stuck" candidates, please find below step-by-step:

  1. Go your job requisition in Recruiting. Click in the candidate name and after that check his history, in the popup URL you you'll notice the following value jobAppId="xxx". Copy the value corresponding to XXX;
  2. Go to Manage Data > Process trigger. In the search box input your application ID;




  3. In the process trigger Object, copy the value for BPE Process Instance  ID;
  4. Go to Admin Center > BPE Monitor, in the filter section input the value that you have copied in step 3, increase the items per page to 100 and search;





  5. In the search you'll notice an event called Onboarding2workflow, click in the event (as per below screenshot);




  6. In the activities section you'll see a CallActivity for External User error flow;




  7. This error confirms that you had an issue during the process restart. As the next step we need to search for the Onboarding2createextusererrorworkflow flow in the events. The event should be near to the other events for your candidate, you can review by the existing timestamps that we have found in the previous steps;




  8. Copy the Process Instance ID from step 8 and go to Admin Center > BPE: Manage Process Tasks (in my case the value was 9d00beb8-9c36-11ea-89ec-0050568516b1);
  9. In Manage Process Tasks, insert the process instance ID in the fiters and search;
  10. Click on the process and click in Restart Task;
  11. Now, go to your homepage and go to  Business Process Error tile and open your process;



  12. Click on restart and you should be able to proceed further;


Keywords

restart, onboarding, 2.0, stuck, process, manager-id, Onboarding2createextusererrorworkflow, Onboarding2workflow , KBA , LOD-SF-OBX , Onboarding 2.0 , How To

Product

SAP SuccessFactors Onboarding

Attachments

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