SAP Knowledge Base Article - Preview

2952313 - REST Adapter with Basic Authentication fails after update/upgrade to Netweaver 7.50 SP17 or higher

Symptom

You have a REST Adapter Receiver channel which is configured with Basic Authentication.

After a system upgrade/update to Netweaver 7.50 SP17 or higher, all the messages processed in this channel started to fail with HTTP 401 or similar HTTP error.

When reproducing the error and capturing an XPI Inspector trace, in the HTTP Client traces, you can see that no Authorization Basic header is set in the request header.


Read more...

Environment

  • SAP NetWeaver 7.5

Product

SAP NetWeaver 7.5

Keywords

Preemptive, HTTP 401, Rest, Basic, Authentication, Security, Upgrade, Update, Fail, Not, Working, Header, Rquest, Process Orchestration 7.5, PI 7.5, PO 7.5, XI, AEX , KBA , BC-XI-CON-RST , Rest Adapter , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.