SAP Knowledge Base Article - Public

2950003 - WFA Measure Page for Derived Measure not showing any data even if Input Measure has Data

Symptom

  • The charts and tables for a derived measure page in WFA does not show any data.
  • Data from input measures exist.
  • The calculation or formula is correct and there is no divide by zero,

Environment

  • SAP SuccessFactors Workforce Analytics
    • WFA on HANA

Reproducing the Issue

1. Login and go to Workforce Analytics
2. Go to the specific Measure page e.g. Workforce Mobility > Recruitment
3. Select the affected measure, e.g. Net Hire Ratio - Silents & Boomers
Result: The chart and tables won't show any data


4. Check the Input page of the measure and you will see that the Input measures for this derived measure has data.

5. Take sample data and compute the result based on the calculation.  The result has decimal places and is less than a whole number. e.g. 0.05

Cause

There is no issue with the measure calculation. This Measure has 0 decimal point in the configuration defined meaning the values will be shown in absolute numbers (not in decimal points).  Now if you calculate the value and the result is less than a whole number, e.g. it is 0.20 (14/69), the data won't be displayed as it rounds off to less than 1.  The decimal points are defined in Global config and so cannot be modified on a specific tenant.

Resolution

As a workaround, since this cannot be changed in the global config,  you can create a custom measure/calculation in Query workspace and set the applicable number of decimal places, e.g. 2.   

Keywords

WFA measure page, decimal places, calculations with decimals, result with decimals, divide with decimals, chart no data , KBA , LOD-SF-WFA-WA , Workforce Anaytics , Product Enhancement

Product

SAP SuccessFactors HXM Core all versions