SAP Knowledge Base Article - Preview

2945438 - Report with Date Parameter not able to set the Current Value in a .NET WEB application

Symptom

We have a custom c# .net web application in user testing that references SAP BI 4.2 SP6. When we try to run some of our Crystal Reports, we are re-prompted to enter the start and stop dates a second time after the reports render with data. No code changes have been made to the web application except for re-referencing the application from SAP 4.1 SP5 to SAP 4.2 SP6. The report is passing the date parameters to a stored procedure which confirmed is returning data and the data is rendered in the report, but the date parameters seem to be lost on printing the data to the report to be rendered.

We also have another custom app where we do not see this behavior.  This app just exports reports.  It does not use report viewers. Support


Read more...

Environment

  • BI Servers: SAP 4.2 SP6 Server is installed.
  • OS: Windows Server 2016 OS Web Server:
  • IIS. SAP 4.2 SP6 Client Tools and .Net SDK are installed.
  • OS: Windows Server 2016 OS Crystal Report Web Reference Used:
  • CrystalDecisions.Web, version 14.0.3500.0
  • CrystalReportViewer Version: 14.0.3500.00

Product

SAP BusinessObjects Business Intelligence platform 4.2

Keywords

.NET, BOE 4.2.6, date parameters , KBA , BI-DEV-NET , BI Software Development Kits (SDKs) - .NET or Other , Bug Filed

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.