SAP Knowledge Base Article - Public

2944990 - IAS Upgrade error when validating S-User credentials

Symptom

  • Receiving "Invalid S-User. Enter the correct S-User for this company" error message when entering S-user credentials for IAS upgrade
  • Unable to complete "Initiate SuccessFactors SAP Cloud Platform Identity Authentication Service Integration" due to error with S-user
  • Receiving "Invalid username/password" error message when entering S-user credentials for IAS upgrade

Environment

  • SAP SuccessFactors HXM Suite
  • SAP Cloud Platform Identity Authentication Service

Reproducing the Issue

  1. Navigate to Upgrade Center
  2. Select "Initiate SuccessFactors Identity Authentication Service Integration"
  3. Pop-up window will appear asking for S-user credentials > enter S-User credentials
  4. Click on "Validate"
  5. One of the below errors appear:
    • Invalid S-User. Enter the correct S-User for this company
    • Invalid username/password

Cause

  1. Error "Invalid S-User. Enter the correct S-User for this company" appears if the S-user ID being entered is not tied to the ERP customer number that the BizX system belongs to.
  2. The error "Invalid username/password" is thrown if it is exceeding the length limit.

Resolution

Please find below how to address the issues related to your S-user ID depending on the error being received.

Invalid S-User. Enter the correct S-User for this company

Make sure you S-user is linked to the customer number that owns the system you are performing the Upgrade. Sometimes, the account is is tied to a Corporate Group Function (CCC) and the user will end up being able to execute functions (for example, report an incident, request SSCR keys, and so on) only for the ERP customer number they were assigned to.

To learn more about Corporate Group (CCC) function, check the below KBA:

2632518 - Information about the SAP Corporate Group (CCC) function

Invalid username/password

Make sure the password being entered is the correct one. Also, use a simple password with 10 characters maximum to avoid issues. In case the password exceeds this limit, please reset your password to proceed, as per the below KBA:

1808560 - How to reset a S-User ID password - SAP ONE Support Launchpad

See Also

  • KBA 2843423 - IAS via Upgrade Center | No tenants created nor credentials email received after running the "Create/Initiate [...]" task
  • KBA 2791410 - Integrating SuccessFactors with SAP Cloud Identity Authentication Through the Upgrade Center

Keywords

S-user error, upgrade IAS error, IAS initiate issues, upgrade, upgrade center, s user, validation, validate, patch , KBA , LOD-SF-PLT-IAS , Identity Authentication Services (IAS) With BizX , Problem

Product

SAP SuccessFactors HXM Suite all versions